Power outage at UNO

Incident Report for IT

Resolved

Power was restored by OPPD at 12:57PM on Friday. All systems are operating normally. This issue is resolved.
Posted Mar 30, 2026 - 09:58 CDT

Identified

OPPD continues to work on this power outage. Additional details are available on the OPPD Outage Map at https://www.myoppd.com/portal/PreOutageMap
Posted Mar 27, 2026 - 13:43 CDT

Investigating

An OPPD power outage is impacting the following UNO buildings: Child Care Center, Thompson Alumni Center, University Village, Maverick Village. Network connectivity in these buildings will be affected until power is restored.

Questions 402-472-3970 or support@nebraska.edu
Posted Mar 27, 2026 - 12:14 CDT
This incident affected: Infrastructure (OMAHA - Wired Network Connections, OMAHA - Wireless Network Connections).