Canvas is experiencing issues due to an ongoing AWS incident

Incident Report for IT

Resolved

All systems are operating normally. This issue is resolved.
Posted Oct 21, 2025 - 09:59 CDT

Monitoring

All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Posted Oct 20, 2025 - 18:13 CDT

Update

ITS is aware that Canvas is still unavailable to most users. Instructure has confirmed that this is related to the ongoing Amazon AWS outage. We continue to monitor the Instructure and AWS status pages for updates on this issue.
Posted Oct 20, 2025 - 16:21 CDT

Identified

We are currently waiting for full recovery due to an ongoing AWS incident. You can follow the status of the issue at https://health.aws.amazon.com/health/status and https://status.instructure.com/
Posted Oct 20, 2025 - 08:34 CDT
This incident affected: Teaching & Learning (Canvas).