ITS Billing under investigation

Incident Report for IT

Resolved

All systems are operating normally. This issue is resolved.
Posted Oct 23, 2025 - 13:07 CDT

Monitoring

All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Posted Oct 22, 2025 - 16:21 CDT

Investigating

A problem with ITS Billing is under investigation. Technicians are investigating the issue.
Reported by Bryan Fitzgerald
Submitted by Loren Frerichs
Questions 402-472-3970 or support@nebraska.edu
Posted Oct 22, 2025 - 14:18 CDT
This incident affected: Administrative & Business (Business Applications (other)).