MS365 under investigation

Incident Report for IT

Monitoring

All issues appear to have subsided, and all systems are performing as expected. We're continuing to monitor for any reoccurring problems.
Submitted by Bryan Fitzgerald
Posted Sep 02, 2026 - 13:13 CDT

Investigating

A problem with MS365 is under investigation. Users may be unable to connect to, or experience degraded functionality with Exchange Online.

Submitted by Bryan Fitzgerald
Questions 402-472-3970 or support@nebraska.edu
Posted Aug 31, 2026 - 11:43 CDT
This incident affects: Communication & Collaboration (Microsoft 365 - Outlook (Exchange Online)).